re = /(EXT|GEN)_CODE\d{1,3}=/m
str = 'EXT_CODE5=PC099|EXT_CODE22=BC054|EXT_CODE4=ZC018|GEN_CODE11=ZV010'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end