#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\-?0[\,\.][0-9]{1,}$)|(^\-?[1-9][0-9]{1,}$)|(^[0-9]$)|(^\-?[1-9][0-9]{0,}[\,\.][0-9]{1,}$)|(^\-?[1-9]$)"
Local $sString = "01" & @CRLF & _
"001" & @CRLF & _
"033" & @CRLF & _
"0000033" & @CRLF & _
"00000.2" & @CRLF & _
"00000000000000" & @CRLF & _
"01010101010" & @CRLF & _
"0000.0" & @CRLF & _
"aaa" & @CRLF & _
"???!!!!!" & @CRLF & _
"111%$$$$" & @CRLF & _
"-0" & @CRLF & _
"-" & @CRLF & _
"" & @CRLF & _
"-100" & @CRLF & _
"-100.255" & @CRLF & _
"-10.25555" & @CRLF & _
"-1.2" & @CRLF & _
"-1335354.12" & @CRLF & _
"-22" & @CRLF & _
"-2" & @CRLF & _
"-1" & @CRLF & _
"-13353544366564547" & @CRLF & _
"-0.22222298" & @CRLF & _
"-0.2" & @CRLF & _
"-0,2989080" & @CRLF & _
"-6767676767676767677676767677676" & @CRLF & _
"-0.22" & @CRLF & _
"-123" & @CRLF & _
"-1" & @CRLF & _
"100.255" & @CRLF & _
"10.25555" & @CRLF & _
"1.2" & @CRLF & _
"1335354.12" & @CRLF & _
"22" & @CRLF & _
"2" & @CRLF & _
"1" & @CRLF & _
"13353544366564547" & @CRLF & _
"0.22222298" & @CRLF & _
"0.2" & @CRLF & _
"0,2989080" & @CRLF & _
"6767676767676767677676767677676" & @CRLF & _
"0" & @CRLF & _
"0.22" & @CRLF & _
"123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")