import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\-?0[\\,\\.][0-9]{1,}$)|(^\\-?[1-9][0-9]{1,}$)|(^[0-9]$)|(^\\-?[1-9][0-9]{0,}[\\,\\.][0-9]{1,}$)|(^\\-?[1-9]$)";
final String string = "01\n"
+ "001\n"
+ "033\n"
+ "0000033\n"
+ "00000.2\n"
+ "00000000000000\n"
+ "01010101010\n"
+ "0000.0\n"
+ "aaa\n"
+ "???!!!!!\n"
+ "111%$$$$\n"
+ "-0\n"
+ "-\n\n"
+ "-100\n"
+ "-100.255\n"
+ "-10.25555\n"
+ "-1.2\n"
+ "-1335354.12\n"
+ "-22\n"
+ "-2\n"
+ "-1\n"
+ "-13353544366564547\n"
+ "-0.22222298\n"
+ "-0.2\n"
+ "-0,2989080\n"
+ "-6767676767676767677676767677676\n"
+ "-0.22\n"
+ "-123\n"
+ "-1\n"
+ "100.255\n"
+ "10.25555\n"
+ "1.2\n"
+ "1335354.12\n"
+ "22\n"
+ "2\n"
+ "1\n"
+ "13353544366564547\n"
+ "0.22222298\n"
+ "0.2\n"
+ "0,2989080\n"
+ "6767676767676767677676767677676\n"
+ "0\n"
+ "0.22\n"
+ "123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}