import re
regex = re.compile(r"(^\-?0[\,\.][0-9]{1,}$)|(^\-?[1-9][0-9]{1,}$)|(^[0-9]$)|(^\-?[1-9][0-9]{0,}[\,\.][0-9]{1,}$)|(^\-?[1-9]$)", flags=re.MULTILINE)
test_str = ("01\n"
"001\n"
"033\n"
"0000033\n"
"00000.2\n"
"00000000000000\n"
"01010101010\n"
"0000.0\n"
"aaa\n"
"???!!!!!\n"
"111%$$$$\n"
"-0\n"
"-\n\n"
"-100\n"
"-100.255\n"
"-10.25555\n"
"-1.2\n"
"-1335354.12\n"
"-22\n"
"-2\n"
"-1\n"
"-13353544366564547\n"
"-0.22222298\n"
"-0.2\n"
"-0,2989080\n"
"-6767676767676767677676767677676\n"
"-0.22\n"
"-123\n"
"-1\n"
"100.255\n"
"10.25555\n"
"1.2\n"
"1335354.12\n"
"22\n"
"2\n"
"1\n"
"13353544366564547\n"
"0.22222298\n"
"0.2\n"
"0,2989080\n"
"6767676767676767677676767677676\n"
"0\n"
"0.22\n"
"123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")