#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ABCD\s+abcd\s+\(\s+[.]\s*X\s*\(x\)\s*,\s*[.]Y\s*\(y\)\s*\)\s*;"
Local $sString = "ABCD abcd (" & @CRLF & _
" . X (x)," & @CRLF & _
" .Y (y)" & @CRLF & _
");" & @CRLF & _
"ABCD1 abcd1 (" & @CRLF & _
" . X1 (x1)," & @CRLF & _
" .Y1 (y1)" & @CRLF & _
");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")