using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ABCD\s+abcd\s+\(\s+[.]\s*X\s*\(x\)\s*,\s*[.]Y\s*\(y\)\s*\)\s*;";
string input = @"ABCD abcd (
. X (x),
.Y (y)
);
ABCD1 abcd1 (
. X1 (x1),
.Y1 (y1)
);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}