$re = '/ABCD\s+abcd\s+\(\s+[.]\s*X\s*\(x\)\s*,\s*[.]Y\s*\(y\)\s*\)\s*;/m';
$str = 'ABCD abcd (
. X (x),
.Y (y)
);
ABCD1 abcd1 (
. X1 (x1),
.Y1 (y1)
);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);