using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/\/\/.*)?facebook\.com(?:\/\S*)?";
string input = @"https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf target=_blank class=button";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}