package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/\/\/.*)?facebook\.com(?:\/\S*)?`)
var str = `https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf target=_blank class=button`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}