$re = '/(?:\/\/\/.*)?facebook\.com(?:\/\S*)?/m';
$str = 'https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf target=_blank class=button';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);