using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"example_(?!example2$)(.+)";
string input = @"example_example2
example_more-text-here
example_noexample2after";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}