re = /example_(?!example2$)(.+)/m
str = 'example_example2
example_more-text-here
example_noexample2after'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end