const regex = /example_(?!example2$)(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('example_(?!example2$)(.+)', 'gm')
const str = `example_example2
example_more-text-here
example_noexample2after`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}