# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(www.|https?:\/\/(?:www.)?)?([a-z-_0-9]*)(?:\.)"
test_str = ("www.xakep.ru\n"
"https://swapi.co/api/planets/12/ //swapi\n"
"http://github.com/carbonfive/raygun //github\n"
"http://www.zombie-bites.com //\n"
"https://www.cnet.com\n"
"http://google.co.jp\n"
"http://github.com/carbonfive/raygun\n"
"https://www.cnet.com\n"
"xewveqmwcz90sl64.co/\n"
"zx06u3ep-tcp8b25l.info\n"
"j4yfack7z7pui8b8j-d3-abfdvp.it/img/\n"
"z8rabv26m.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.