// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(www.|https?:\/\/(?:www.)?)?([a-z-_0-9]*)(?:\.)").unwrap();
let string = "www.xakep.ru
https://swapi.co/api/planets/12/ //swapi
http://github.com/carbonfive/raygun //github
http://www.zombie-bites.com //
https://www.cnet.com
http://google.co.jp
http://github.com/carbonfive/raygun
https://www.cnet.com
xewveqmwcz90sl64.co/
zx06u3ep-tcp8b25l.info
j4yfack7z7pui8b8j-d3-abfdvp.it/img/
z8rabv26m.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}