import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{4})(\\s*|\\/|[-]|[.])([0-1][0-9])(\\s*|\\/|[-]|[.])([0-9]{2})$";
final String string = "January 14, 2018\n\n"
+ "2018/07/18\n"
+ "20180718\n"
+ "2018.07.18\n"
+ "2018-08-18\n"
+ "181007\n"
+ "20181202\n"
+ "201107\n"
+ "921109\n\n"
+ "13 กันยายน 2535\n\n"
+ "1ธันวาคม2561\n\n"
+ "1ธันวา2561\n\n"
+ "5 กันยา 61\n\n"
+ "1กันยา2501\n\n"
+ "1 September 2018\n\n"
+ "15October18\n\n"
+ "1/9/2018\n\n"
+ "10/3/2018\n\n"
+ "12/12/2018\n\n"
+ "4 กันยา 2018\n\n"
+ "12-12-18\n\n"
+ "12-9-2018\n\n"
+ "12Sep 2018\n\n"
+ "15มีนาคม 2018\n\n"
+ "15.Sep.2018";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}