import re
regex = re.compile(r"^([0-9]{4})(\s*|\/|[-]|[.])([0-1][0-9])(\s*|\/|[-]|[.])([0-9]{2})$", flags=re.MULTILINE)
test_str = ("January 14, 2018\n\n"
"2018/07/18\n"
"20180718\n"
"2018.07.18\n"
"2018-08-18\n"
"181007\n"
"20181202\n"
"201107\n"
"921109\n\n"
"13 กันยายน 2535\n\n"
"1ธันวาคม2561\n\n"
"1ธันวา2561\n\n"
"5 กันยา 61\n\n"
"1กันยา2501\n\n"
"1 September 2018\n\n"
"15October18\n\n"
"1/9/2018\n\n"
"10/3/2018\n\n"
"12/12/2018\n\n"
"4 กันยา 2018\n\n"
"12-12-18\n\n"
"12-9-2018\n\n"
"12Sep 2018\n\n"
"15มีนาคม 2018\n\n"
"15.Sep.2018")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")