#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<TopicSet FormalName="PARENT1">)([\s\S]*?)(<\/TopicSet>)"
Local $sString = "<TopicSet FormalName="PARENT1">" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child1" />" & @CRLF & _
" </Topic>" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child2" />" & @CRLF & _
" </Topic>" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child3" />" & @CRLF & _
" </Topic>" & @CRLF & _
"</TopicSet>" & @CRLF & _
"<TopicSet FormalName="PARENT2">" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child1" />" & @CRLF & _
" </Topic>" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child2" />" & @CRLF & _
" </Topic>" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child3" />" & @CRLF & _
" </Topic>" & @CRLF & _
"</TopicSet>"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)