// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<TopicSet FormalName="PARENT1">)([\s\S]*?)(<\/TopicSet>)"#).unwrap();
let string = "<TopicSet FormalName=\"PARENT1\">
<Topic>
<TopicType FormalName=\"Child1\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child2\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child3\" />
</Topic>
</TopicSet>
<TopicSet FormalName=\"PARENT2\">
<Topic>
<TopicType FormalName=\"Child1\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child2\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child3\" />
</Topic>
</TopicSet>";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}