package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)A\d{7,8}00`)
var str = `ABC12345678CRP1234567F2801209A1234567800<<<33`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}