const regex = /A\d{7,8}00/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('A\\d{7,8}00', 'gm')
const str = `ABC12345678CRP1234567F2801209A1234567800<<<33`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}