# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\,|\+|\~|\>|\(|\)|\[|\]|\{|\}|^)(?<s>\s*)(?<tag>a|div|p|span|img|button)(?!\s*\[[^\]]*__canvas[^\]]*\])(?=[\:\,\+\~\>\(\)\[\]\{\}\s]+)(?=[^\}\;]*[\{])/${s}${tag}[__canvas]/gm;t' <<< "@media only screen and (max-width: 600px) {
div>a[__canvas]:hover,a,div {
background-color: lightblue;
}
i+img>audio,table:not(a+p),
button~.a
,
span{
background-color: lightblue;
}
}
a {
background: url(http://a.b.com);
font-family: cursive, a, serif;
}
img
{
color: a;
font-family: a, serif;
}"