import Foundation
let pattern = #"(?<=\,|\+|\~|\>|\(|\)|\[|\]|\{|\}|^)(?<s>\s*)(?<tag>a|div|p|span|img|button)(?!\s*\[[^\]]*__canvas[^\]]*\])(?=[\:\,\+\~\>\(\)\[\]\{\}\s]+)(?=[^\}\;]*[\{])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
@media only screen and (max-width: 600px) {
div>a[__canvas]:hover,a,div {
background-color: lightblue;
}
i+img>audio,table:not(a+p),
button~.a
,
span{
background-color: lightblue;
}
}
a {
background: url(http://a.b.com);
font-family: cursive, a, serif;
}
img
{
color: a;
font-family: a, serif;
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${s}${tag}[__canvas]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)