$re = '/(?<=\,|\+|\~|\>|\(|\)|\[|\]|\{|\}|^)(?<s>\s*)(?<tag>a|div|p|span|img|button)(?!\s*\[[^\]]*__canvas[^\]]*\])(?=[\:\,\+\~\>\(\)\[\]\{\}\s]+)(?=[^\}\;]*[\{])/m';
$str = '@media only screen and (max-width: 600px) {
div>a[__canvas]:hover,a,div {
background-color: lightblue;
}
i+img>audio,table:not(a+p),
button~.a
,
span{
background-color: lightblue;
}
}
a {
background: url(http://a.b.com);
font-family: cursive, a, serif;
}
img
{
color: a;
font-family: a, serif;
}';
$subst = "${s}${tag}[__canvas]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;