package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:.*? )?(?:[Ll]ist|[Tt]able|[Ff]igure)\s+\d+(?:-\d+)?):\s+(.+)`)
var str = `Text Table 6-2: Management of children study and actions`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}