import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:.*? )?(?:[Ll]ist|[Tt]able|[Ff]igure)\\s+\\d+(?:-\\d+)?):\\s+(.+)";
final String string = "Text Table 6-2: Management of children study and actions";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}