using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<table[^>]*>(.*?)<\/table>";
string input = @"<table id=""tbl"" class=""table-fill"">
<thead>
<tr>
<th>IP</th>
<th>Port</th>
<th>Anonymity</th>
<th>Country</th>
</tr>
</thead>
<tbody id=""tabli"" class=""table-hover"">
<tr>
<td>84.17.51.209</td>
<td>3128</td>
<td>Transparent</td>
<td>United Kingdom</td>
</tr>
<tr>
<td>84.17.51.209</td>
<td>3128</td>
<td>Transparent</td>
<td>United Kingdom</td>
</tr>
</table>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}