package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)<table[^>]*>(.*?)<\/table>`)
var str = `<table id="tbl" class="table-fill">
<thead>
<tr>
<th>IP</th>
<th>Port</th>
<th>Anonymity</th>
<th>Country</th>
</tr>
</thead>
<tbody id="tabli" class="table-hover">
<tr>
<td>84.17.51.209</td>
<td>3128</td>
<td>Transparent</td>
<td>United Kingdom</td>
</tr>
<tr>
<td>84.17.51.209</td>
<td>3128</td>
<td>Transparent</td>
<td>United Kingdom</td>
</tr>
</table>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}