using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"button_\K[^,]+|,location_\K[^,]+|,\K[^_]+(?=_text)";
string input = @"button_reset,location_text,email_text";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}