$re = '/button_\K[^,]+|,location_\K[^,]+|,\K[^_]+(?=_text)/';
$str = 'button_reset,location_text,email_text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);