re = /button_\K[^,]+|,location_\K[^,]+|,\K[^_]+(?=_text)/
str = 'button_reset,location_text,email_text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end