#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=MARKER\n)(?:(?!MARKER)[^\0])+\Z"
Local $sString = "MARKER" & @CRLF & _
"aaa" & @CRLF & _
"bbb" & @CRLF & _
"ccc" & @CRLF & _
"MARKER" & @CRLF & _
"ddd" & @CRLF & _
"eee" & @CRLF & _
"fff" & @CRLF & _
"MARKER" & @CRLF & _
"ggg" & @CRLF & _
"hhh" & @CRLF & _
"iii" & @CRLF & _
"MARKER" & @CRLF & _
"jjj" & @CRLF & _
"kkk" & @CRLF & _
"lll" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")