re = /(?<=MARKER\n)(?:(?!MARKER)[^\0])+\Z/m
str = 'MARKER
aaa
bbb
ccc
MARKER
ddd
eee
fff
MARKER
ggg
hhh
iii
MARKER
jjj
kkk
lll
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end