import re
regex = re.compile(r"(?<=MARKER\n)(?:(?!MARKER)[^\0])+\Z", flags=re.MULTILINE)
test_str = ("MARKER\n"
"aaa\n"
"bbb\n"
"ccc\n"
"MARKER\n"
"ddd\n"
"eee\n"
"fff\n"
"MARKER\n"
"ggg\n"
"hhh\n"
"iii\n"
"MARKER\n"
"jjj\n"
"kkk\n"
"lll\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")