$re = '/\<.+?\>/';
$str = '彼女は<font color="#ff0000"><font color="#ff0000">看護婦</font></font>です。';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);