re = /\<.+?\>/
str = '彼女は<font color="#ff0000"><font color="#ff0000">看護婦</font></font>です。'
# Print the match result
str.match(re) do |match|
puts match.to_s
end