package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:Created by|Designer):(.*)`)
var str = `Created by:Wiktor
Designer:#1
Created by:Somebody like you
Designer:#2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}