re = /(?:Created by|Designer):(.*)/i
str = 'Created by:Wiktor
Designer:#1
Created by:Somebody like you
Designer:#2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end