const regex = /\S+?@gmail.com,\S{64}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+?@gmail.com,\\S{64}$', 'gm')
const str = `эта строка не подходит под описание
Почта@gmail.com,401ff14043c744fb5b10b28cfafbcf00fcffcc92e23c18b1bade7b1fdbbb0c04
эта тоже
Почта@gmail.com,daaad6e5604e8e17bd9f108d91e26afe6281dac8fda0091040a7a6d7bd9b43b5
эта_почти_подходит_но_тут_символов_не_65@gmail.com,11daaad6e5604e8e17bd9f108d91e26afe6281dac8fda0091040a7a6d7bd9b43b5
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}