use strict;
my $str = 'эта строка не подходит под описание
Почта@gmail.com,401ff14043c744fb5b10b28cfafbcf00fcffcc92e23c18b1bade7b1fdbbb0c04
эта тоже
Почта@gmail.com,daaad6e5604e8e17bd9f108d91e26afe6281dac8fda0091040a7a6d7bd9b43b5
эта_почти_подходит_но_тут_символов_не_65@gmail.com,11daaad6e5604e8e17bd9f108d91e26afe6281dac8fda0091040a7a6d7bd9b43b5
';
my $regex = qr/\S+?@gmail.com,\S{64}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}