// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S+?@gmail.com,\S{64}$").unwrap();
let string = "эта строка не подходит под описание
Почта@gmail.com,401ff14043c744fb5b10b28cfafbcf00fcffcc92e23c18b1bade7b1fdbbb0c04
эта тоже
Почта@gmail.com,daaad6e5604e8e17bd9f108d91e26afe6281dac8fda0091040a7a6d7bd9b43b5
эта_почти_подходит_но_тут_символов_не_65@gmail.com,11daaad6e5604e8e17bd9f108d91e26afe6281dac8fda0091040a7a6d7bd9b43b5
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}