#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\{[^{}:]*:[^:{}]*}|[^{:}])+$"
Local $sString = "Valid case: " & @CRLF & _
"{test:test1} {test2:test3} test4 test5" & @CRLF & _
"Invalid case:" & @CRLF & _
"{test:}, {test1: test2, test1: test3}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")