package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\{[^{}:]*:[^:{}]*}|[^{:}])+$`)
var str = `Valid case:
{test:test1} {test2:test3} test4 test5
Invalid case:
{test:}, {test1: test2, test1: test3}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}