import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![ -]|\\d+$)(?:(?![ -]$)[\\pL\\pN -])+$";
final String string = "Street\n"
+ "Some-Street\n"
+ "Street\n"
+ "1 st street\n"
+ "street 5\n\n"
+ "Street \n"
+ " Street\n"
+ "Street-\n"
+ "-Street\n"
+ "111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}