$re = '/^(?![ -]|\d+$)(?:(?![ -]$)[\pL\pN -])+$/m';
$str = 'Street
Some-Street
Street
1 st street
street 5
Street
Street
Street-
-Street
111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);