use strict;
my $str = 'Obsolete #:748275
New #:748275
Hello world 748275
daslfjcas 4546 odiue
sdfijvsd4567878dfjkvlsd';
my $regex = qr/(?<!Obsolete #:)\b(\d{6})\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}