$re = '/(?<!Obsolete #:)\b(\d{6})\b/m';
$str = 'Obsolete #:748275
New #:748275
Hello world 748275
daslfjcas 4546 odiue
sdfijvsd4567878dfjkvlsd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);