re = /(?<!Obsolete #:)\b(\d{6})\b/m
str = 'Obsolete #:748275
New #:748275
Hello world 748275
daslfjcas 4546 odiue
sdfijvsd4567878dfjkvlsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end