$re = '/(?<=Application Name:\s{7})[^\n]*(?=[^=]*(?=Secret Key))|(?<=Secret Key:\s{13})[^\n]*/';
$str = 'Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Secret Key: XYZ86JBHHSD
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Secret Key: XYZ86JBHHSD
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);