# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=Application Name:\s{7})[^\n]*(?=[^=]*(?=Secret Key))|(?<=Secret Key:\s{13})[^\n]*"
test_str = ("Application Details for the XYZ application:\n"
" =========================================================\n\n"
" Application Name: XYXZW\n"
" Application Id: XYZ353WERX\n"
" Secret Key: XYZ86JBHHSD\n\n"
"Application Details for the XYZ application:\n"
" =========================================================\n\n"
" Application Name: XYXZW\n"
" Application Id: XYZ353WERX\n\n"
"Application Details for the XYZ application:\n"
" =========================================================\n\n"
" Application Name: XYXZW\n"
" Application Id: XYZ353WERX\n"
" Secret Key: XYZ86JBHHSD\n\n"
"Application Details for the XYZ application:\n"
" =========================================================\n\n"
" Application Name: XYXZW\n"
" Application Id: XYZ353WERX")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.